Conectar Excel y Google Sheets a la Data API

Última actualización · Ver como markdown

Puede extraer datos de la AMMP Data API directamente en Excel o Google Sheets para sus propios análisis e informes, y actualícelos a petición. Necesitará una clave de API; consulte Gestión de usuarios.

Para consultar datos de AMMP desde un asistente de IA en su lugar, consulte Servidor AMMP MCP.

Excel

Hay dos formas de conectarse: comenzar desde una plantilla de AMMP o añadir las consultas de AMMP a un libro existente. Un recorrido en video muestra la ruta de la plantilla.

Uso de la plantilla de AMMP

  1. Preguntar support@ammp.io para obtener la plantilla más reciente. Existen plantillas para diferentes datos, como energía o potencia histórica; los endpoints correspondientes se indican en el Documentación de la Data API.
  2. Abra la plantilla y haga clic en Habilitar edición y Habilitar contenido.
  3. Go to Datos → Obtener datos → Opciones de consulta → Libro actual (Privacidad) y selecciona Ignorar niveles de privacidad, para que Excel pueda obtener datos externos.
  4. Haz clic Iniciar el Editor de Power Query.
  5. Bajo Parámetros de entrada, abra Ingrese su clave de API y pega tu clave.
  6. Establece la fecha de inicio en Fecha desde (yyyy-MM-dd). En la plantilla de potencia, usa Ingrese la hora de inicio (yyyy-MM-dd hh:mm:ss, con un espacio antes de la hora).
  7. Establece la fecha de finalización en Fecha hasta de la misma manera.
  8. Configurar Intervalo: 1d para diario o 1M para la energía mensual; 1h or 15m en la plantilla de potencia.
  9. Haz clic Actualizar todo. Sus activos se cargan en Paso 5: Seleccionar los activos. Si una barra amarilla con Editar credenciales aparezca, haz clic en él y luego Conectar.
  10. Para usar solo algunos activos, filtre asset_id columna.
  11. Comprueba el resultado en Salida → Salida.
  12. Haz clic Cerrar y cargar, luego Datos → Consultas y conexiones.
  13. Clic derecho Salida y elija Cargar en… para colocar los datos en una hoja.

Resolución de problemas

  • Error de firewall: repita el paso 3 (Ignore privacy levels).
  • No se muestran activos: en Power Query, active Ver → Configuración de consultas, seleccione Paso 5: Seleccionar los activos, y elimina cualquier Filas filtradas paso en Applied Steps.
  • Actualización del periodo: abrir Datos → Consultas y conexiones, haga doble clic en el parámetro, cámbielo, haga clic en Cerrar y cargar, luego haga clic en Actualizar todo dos veces (dos clics independientes).

Añadir datos de AMMP a un libro de trabajo existente

  1. Abra su libro de trabajo y la plantilla de AMMP, e inicie el Editor de Power Query en ambos.
  2. Copia todas las consultas de la plantilla y pégalas en la lista de consultas de tu libro de trabajo.
  3. Continúa desde el paso 2 de las instrucciones de la plantilla.

Google Sheets

Google Sheets no tiene plantilla, ya que cada usuario instala el complemento de la API por su cuenta.

  1. Instala el SyncWith | Any API complemento y, a continuación, abra Extensiones → SyncWith | Any API → Launch sidebar.
  2. Elegir Personalizado en la parte inferior de la lista.
  3. Crear un POST solicitud al endpoint de token de la Data API (consulte la Documentación de la Data API) con dos encabezados: accept: application/json y x-api-key: <your API key>.
  4. Haz clic Vista previa para comprobar que devuelve un token y, a continuación, Insertar en la primera hoja.
  5. Crea solicitudes adicionales para los endpoints que necesites, utilizando referencias de celda para el token y los parámetros de consulta. Consulta la guía de SyncWith sobre referencias de celdas.

Consejo

Una referencia de celda que apunta a un rango, como una columna de ID de activos, realiza una llamada a la API por celda. Es una forma fácil de extraer datos de muchos activos a la vez.

También puede programar actualizaciones. Los tokens caducan, así que asegúrese de que la programación renueve la solicitud de token antes de las solicitudes de datos.